В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DashaHB16
DashaHB16
09.04.2021 01:54 •  Информатика

Написать программу на языке паскаль, которая подсчитывает количество двоек, троек, четверок и пятерок, полученных за к/р в классе из 20 человек.

Ответ:
Аньсминожек
Аньсминожек
08.10.2020 02:06
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(20,2,5); a.Println;
  var r:=a.GroupBy(t->t).Select(t->(t.Key,t.Count)).OrderBy(t->t[0]);
  foreach var v in r do Writeln(v[0],': ',v[1])
end.
0,0(0 оценок)
Ответ:
GameNooB
GameNooB
08.10.2020 02:06
Program ;
var puple_count,mark,two, three, four, five, i: integer;
begin
writeln('Введите количество учеников');
readln(puple_count);
writeln('Введите оценки');
for i:=1 to puple_count do
begin
readln(mark);
case mark of
2 : two := two + 1;
3 : three := three + 1;
4 : four := four + 1;
5 : five := five + 1;
end;
end;
writeln('5: ', five);
writeln('4: ', four);
writeln('3: ', three);
writeln('2: ', two);
end.
Написать программу на языке паскаль, которая подсчитывает количество двоек, троек, четверок и пятеро
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?