В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Jora2001Voronov
Jora2001Voronov
01.02.2021 20:43 •  Информатика

Напишите программу, которая вводит натуральное число n и выводит на экран чётные положительные степени числа 2, не большие, чем 2 n , в порядке убывания.

Ответ:
dinara56437
dinara56437
08.10.2020 02:01

program HelloWorld;

 

var N: integer;

var i,ii: integer;

var y: real;

 

begin

    writeln('Введите значение N:');

    readln(N);

   

    for i:=N downto 2 do

     if i mod 2 = 0 then

     begin

         y := 2;

         for ii:=1 to i-1 do

           y := y*2;        

         writeln(y:10:0);

     end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?