В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

20 ! написать программу в написать программу обработки массива размерности n, которая подсчитывает кол-во элементов, которые одновременно делятся на 5 и 2. n=6

Ответ:
idkjfsk
idkjfsk
08.10.2020 01:55
Если число k одновременно делится на числа p и q, оно также делится на их произведение p×q. Это позволяет упростить проверку и сделать программу оптимальнее.

// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Элементы массива:',ReadInteger('n='));
  Writeln('Найдено элементов ',a.Where(t->t mod 10=0).Count)
end.

Пример
n= 6
Элементы массива: -38 40 -60 35 0 18
Найдено элементов 3
0,0(0 оценок)
Ответ:
NastyaK27
NastyaK27
08.10.2020 01:55
Var n,i:integer;
A:array[1..6]of integer;
begin
randomize;
for i:=1 to 6 do begin A[i]:=random(100);
Write(A[i], ' ');
end;
for i:=1 to 6 do begin
if (A[i] mod 5=0)and(A[i]mod 2=0) then n:=n+1;
end;
Writeln('kolichest=',n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?