В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ykub321
ykub321
25.02.2020 09:50 •  Информатика

Люди, написать программу в паскале. нужно,чтобы сравнивалась дробная и целая часть вещественного числа,если она одна и та же,то тру,если нет,то false. допустим 12.12 будет тру,а если нет,то фолс. проблема в том,что через fruc и int сравнивается 12 и 0.12. домножать на 100 нельзя,тк это универсальная программа,может быть и число 123.123

Ответ:
grechko8885
grechko8885
08.10.2020 01:43
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadReal('Введите число:').ToString.ToWords('.');
  if a.Length=2 then Writeln(a[0]=a[1])
  else Writeln(False);
end.

Примеры
Введите число: 121.121
True

Введите число: 12.11999
False
0,0(0 оценок)
Ответ:
guka070806
guka070806
08.10.2020 01:43
Var
  V: real;
  c,b: integer;
begin
  writeln('Введите число');
  readln(V);
  c:=round(V);
  V:=V-c;
  b:=c;
  while c>0 do begin
     c:=c div 10;
     V:=V*10;
  end;
  c:=round(V);
  V:=V-c;
  if round(V*10000)<>0 then
     writeln('части не равны')
  else begin
    if b=c then
      writeln('части равны') 
    else
       writeln('части не равны');
  end;
    
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?