В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Raterford
Raterford
26.03.2021 08:22 •  Информатика

Язык программирования - c++. напишите программу, которая вводит натуральное число n и находит все совершенные чис- ла в диапазоне от 1 до n.

Ответ:
Черепашка312
Черепашка312
08.10.2020 01:13
#include <iostream>
using namespace std;

int main()
{
   int n = 0;
   cin >> n;
   for (int i = 1; i <= n; ++i) { 
      int a = 0;
      for (int j = 1; j < i; ++j) {
         if (i % j == 0) {
            a += j;
         }
      }
      if (a == i) {
         cout << i << endl;
      }
   }
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?