Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
sana1998d
29.04.2022 03:00 •
Информатика
Составить программу, проверяющую есть ли цифра n в числе , введённом с клавиатуры. pascal abc. (не копируйте с других источников, неправильно)
Ответ:
вор9
08.10.2020 01:12
Program n1;
var a,n: integer;
f: byte;
begin
f:=0;
readln(a,n);
while a<>0 do
begin
if a mod 10=n then f:=1;
a:=a div 10;
end;
if f=1 then write('цифра ',n,' присутствует в числе')
else write('в числе нет цифры ',n);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
loloika
13.03.2023 02:11
Чем отличается центральная и оперативная память...
виктория123600
14.11.2021 06:36
§4 с чего обеспечивается быстрый доступ к различным устройствам и компьютера? какие значики чаше всего присутствуют на робочем столе? для чего они нужны? ну я так знаюино не...
andreiantipov1
16.08.2020 09:04
Необходимо, чтоб программа выводила на экран вот такую последовательность: 7 14 21 28 35 42 49 56 63 70 77 84 91 98 Python...
artemalashev
22.05.2021 14:03
Напишите программу, которая в последовательности натуральных чисел определяет определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход количество...
lolsasafd
25.03.2020 18:03
Основные преимущества которые дает обработка информации с электронных таблиц по сравнению с оработкой вручную...
inomgafur
11.05.2023 17:03
1) В процессе преобразования растрового графического изображения количество цветов уменьшилось с 256 до 8. Во сколько раз уменьшится объем занимаемой им памяти? 2) Какой объем...
ryzhofftosha20
05.06.2022 10:49
Составить текст из 3 предложений с названиями птиц которые живут у нас зимой....
kadieva1976
05.06.2022 10:49
Из какого слова нельзя получить другое слово добавив гласной буквы в начале леньков стул кран корь...
Празеодим
05.06.2022 10:49
Из 21 кг свежей малины получается 3 кг сухой. сколько взяли свежей малины, если получили 5 кг сухой? с . заранее !...
raivon2005new
05.06.2022 10:49
(2 5/9-1 20/21): 1 8/49+1 8/9: 6 решить пример ....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,n: integer;
f: byte;
begin
f:=0;
readln(a,n);
while a<>0 do
begin
if a mod 10=n then f:=1;
a:=a div 10;
end;
if f=1 then write('цифра ',n,' присутствует в числе')
else write('в числе нет цифры ',n);
end.