В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
wigler
wigler
04.12.2020 13:12 •  Информатика

Составьте программу для вычисления суммы чисел кратных 8 вдиапазоне от а до b. java

Ответ:
Efendieva2004
Efendieva2004
08.10.2020 01:06
Import java.util.Scanner;

class Strange
{
    public static void main (String[] args)
    {
        Scanner sc = new Scanner(System.in);
        int a = sc.nextInt();
        int b = sc.nextInt();
        sc.close();
        int r = a % 8;
        if (r != 0) a += 8 - r;
        int s = 0;
        for (int i=a; i <= b; i+=8) s += i;
        System.out.println("Сумма:" + s);
    }
}

Составьте программу для вычисления суммы чисел кратных 8 вдиапазоне от а до b. java
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?