В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nurpaik
nurpaik
25.09.2022 21:52 •  Информатика

Составить программу вычисления среднего арифметического первых 50 чисел много

Ответ:
UlianaIvleva
UlianaIvleva
08.10.2020 01:00
Вычисляется среднее арифметическое первых 50 НАТУРАЛЬНЫХ чисел.
var i,s: integer;
begin
s:=0;
for i:=1 to 50 do s:=s+i;
writeln('s = ',s/50:4:1);
end.

Результат:
s = 25.5

Или так:
// Сумма первых n членов арифметической прогрессии S=(a1+an)/2*n
// Среднее арифметическое = S/n = (a1+an)/2
begin
 writeln((1+50)/2:4:1);
end.
0,0(0 оценок)
Ответ:
эма24
эма24
08.10.2020 01:00
//PascalABC.NET
//Версия 3.3, сборка 1634
begin
//предполагаются первые 50 натуральных чисел
write('срзнач: ',range(1,50).Average);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?