В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
тамок
тамок
05.11.2022 17:00 •  Информатика

Нужна с массивом. известно количество учащихся в каждом из к классов школ. составить программу, которая определяет, сколько всего учащихся обучается в тех классах школы, в которых меньше, чем 30 человек. заранее

Ответ:
VanoK48
VanoK48
10.08.2020 22:16
Var sum{кол-во учащихся, ответ},k,i:integer;
      a:array[1..1000] of integer;
begin
readln(k);  
sum:=0;
For i:=1 to k do
  readln(a[i]);
For i:=1 to k do
   If a[i]<30 then    {Если кол-во учащихся в классе <30 то прибавляем}
      sum:=sum+30;
writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?