В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Loomina
Loomina
15.07.2020 21:19 •  Информатика

Напишите программу на с++, которая вводит натуральное число n и выводит на экран все натуральные числы, не превосходящие n и делящуеся на каждую из своих цифр

Ответ:
fhdhkfhydkfhs
fhdhkfhydkfhs
08.10.2020 00:50
#include <bits/stdc++.h>

using namespace std;

int main()
{
   int n; cin >> n;
   for (int i = 1; i <= n; ++i)
   {
       int tmp = i;
       bool fl = true;
       while (tmp) {
            int x = tmp % 10;
             if (x != 0)
                if (i % x != 0)
                  fl = false;
              if (!x) fl = false;
            tmp /= 10;
       }
       if (fl) cout << i << ' ';
   }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?