Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
dolgikof
28.09.2021 08:48 •
Информатика
Решить с паскаль №3.определить, является ли слово "перевертышем", №4.печать всех делителей натурального числа a, №5.печать всех совершенных чисел до 10000.
Ответ:
НеизвестныйНикнейм
21.08.2020 11:17
//PascalABC.NET
//Версия 3.3, сборка 1634 (14.02.2018)
1)
begin
var a:=ReadString('Введите слово->').ToLower;
Println(a=ReverseString(a)?'Перевертыш':'Не перевертыш');
end.
Пример(1):
Введите слово-> Комок
Перевертыш
Пример(2):
Введите слово-> Револьвер
Не перевертыш
2)
begin
var a:=ReadInteger('Число-> ');
Range(1,a).Where(t->a mod t=0).Println;
end.
Пример:
Число-> 100
1 2 4 5 10 20 25 50 100
3)
begin
for var i:=2 to 10000 do
begin
var a:=Range(1,i-1).Where(t->i mod t=0).Sum;
if a=i then Write(i,' ');
end;
end.
ответ:
6 28 496 8128
0,0
(0 оценок)
Популярные вопросы: Информатика
новенькая10
17.03.2021 05:44
Як видкрыати проект створеный у середовищи скретч и керувати його виконаням...
potracheno666
18.05.2020 12:23
30 ! , заранее ) от этой зависит моя оценка за четверть, поэтому как можно быстрее написать решение, вот сама : составьте программу на языке паскаль. имеется массив на 20 чисел,...
Nazar21793
17.12.2022 18:17
Информатика. Составить программу True,False. Язык Python. Задание 1-3,5-7...
СоняШундик
29.09.2020 06:10
Найти числовые характеристики x-1 2 3 4 5 8 p 0,1 0,3 a 0,2 0,1 0,1...
slava531
29.09.2020 06:10
2sinx-3cosx=0 (решите, и объясните)...
Soqr
29.09.2020 06:10
А.гайдар - это классик или современник?...
rrrl1
29.09.2020 06:10
Решить : биссектрисы углов параллелограмма, периметр которого 24 см, пересекаются на противолежащей стороне. найдите большую сторону параллелограмма....
m5zapir
29.09.2020 06:10
По каким кровеносным бежит кровь очищенная кислородом?...
star666
29.09.2020 06:10
Расскажите как сложить и вычесть десятичные дроби? решить 4.57+328.586 б)0.64+13.981 в)9.35+72.3...
Sashattop
29.09.2020 06:10
Вуравнении 4x²+49x+4k=0 найти то значение k, при котором его корни x_{1} и x_{2} удовлетворяют уравнению 12 x_{1} + 8 x_{2}=-95...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
//Версия 3.3, сборка 1634 (14.02.2018)
1)
begin
var a:=ReadString('Введите слово->').ToLower;
Println(a=ReverseString(a)?'Перевертыш':'Не перевертыш');
end.
Пример(1):
Введите слово-> Комок
Перевертыш
Пример(2):
Введите слово-> Револьвер
Не перевертыш
2)
begin
var a:=ReadInteger('Число-> ');
Range(1,a).Where(t->a mod t=0).Println;
end.
Пример:
Число-> 100
1 2 4 5 10 20 25 50 100
3)
begin
for var i:=2 to 10000 do
begin
var a:=Range(1,i-1).Where(t->i mod t=0).Sum;
if a=i then Write(i,' ');
end;
end.
ответ:
6 28 496 8128