В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу на языке программирования паскаль в результате выполнения которого получалась сумма всех элементов массива

Ответ:
stardark03
stardark03
08.10.2020 00:40
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  Writeln('S=',a.Sum)
end.

Пример
n= 13
-33 4 19 46 -23 19 -32 31 -10 48 -13 -32 -10
S=14
0,0(0 оценок)
Ответ:
ikonnikoval
ikonnikoval
08.10.2020 00:40
Var a: array  [1..20] of integer;    i: integer;    sum: integer;begin
 sum:=0; for i:=1 to 20 do begin                   a[i] := random(20);                   write(a[i],' ');                   sum:= sum+a[i];              end;               writeln(); writeln('Сумма всех элементов : ',sum); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?