Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
34234252
12.12.2022 00:38 •
Информатика
:в массиве из 8 элементов, заполненном числами в диапазоне от -12 до 12, найти среднее арифметическое, произведение отриц. чисел, кол-во четных и элемент 1. создание массива 2. заполнение массива 3. посчитать 4. вывод )
Ответ:
алеся678
08.10.2020 00:33
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
begin
var mas:=ArrRandom(8,-12,12); mas.Println;
Writeln('среднее арифметическое=',mas.Average);
Writeln('произведение отриц. чисел=',mas.Where(t->t<0).Aggregate(biginteger(1),(x,y)->x*y));
Writeln('кол-во четных=',mas.Where(t->t mod 2=0).Count);
Writeln('максимальный элемент=',mas.Max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Akhmed2387
17.09.2020 15:47
Введите число рублей: 4Введите число копеек: 65Введите число корзин с попкорном: 1465 10Корзина с попкорном вкинотеатре стоит а рублей и Бкопеек. Посчитай, сколько...
dasha5334678
26.11.2020 23:01
Подойдет ли операционная система mac на ультрабук x200m? ?...
dianadiii
26.11.2020 23:01
1)определите значение переменной a после использования данного алгоритма: a : = 36 b : =a/ 12 b: =b+a/*4 a : = a/b*3 порядок действий соответствует правилам арифметики....
Дориана01
28.07.2022 23:25
Создание конуса, цилиндра и сферы Установи соответствие между указанными числовыми значениями и выполненными действиями, Количество соединений: 4 Core Core Translato...
Adelka715
01.05.2020 23:17
1) найти занимаемый изображением объём памяти разрешением в 1024 х 768 пикселей и глубиной цвета 16 бит на 1 пиксель 2)найти максимально возможное количество цветов...
ярик467
01.10.2020 08:36
1. Расшифровать конфигурацию видеокарты: Видеокарта PCI-E 1024МБ MSI «N560GTX-TI Twin Frozr II/OC» (GeForce GTX 560 Ti, DDR5, D-Sub, 2xDVI, mini-HDMI) (ret) 2. Расшифровать...
BULATIKSPB
31.01.2023 19:27
Скажите гейшин с интернетом?...
Kylaguzzz
01.04.2020 08:53
Упростить выражение дам 15б...
sane08one
05.06.2020 09:26
Павел присылает Максиму фотографии, а он ему аудиофайлы. Передача происходит по одному каналу связи с пропускной 80 Кбит/с.Павел отправил изображение с разрешением...
peterick22
02.06.2023 09:48
На python.в массиве из 10 вещественных чисел отсортировать в порядке убывания все отрицательные элементы. положительные и нулевые элементы оставить на своих местах....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var mas:=ArrRandom(8,-12,12); mas.Println;
Writeln('среднее арифметическое=',mas.Average);
Writeln('произведение отриц. чисел=',mas.Where(t->t<0).Aggregate(biginteger(1),(x,y)->x*y));
Writeln('кол-во четных=',mas.Where(t->t mod 2=0).Count);
Writeln('максимальный элемент=',mas.Max);
end.