В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
RomansPirs
RomansPirs
22.06.2020 15:32 •  Информатика

Создать программу python напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. пример: введите два числа: 10 -15 10*(-15)=-150

Ответ:
yasasmail
yasasmail
08.10.2020 00:30
A=int(input('a = '));
b=int(input('b = '));
if (((a<0) & (b>0)) | ((a>0) & (b<0))): sgn=1;
else: sgn=0;
if (a<0): a=-a;
if (b<0): b=-b;
c=0;
while (a>0):
    if ((a & 1)==1): c+=b;
    a>>=1;
    b<<=1;
if (sgn==1): print('результат: ',-c);
else: print('результат: ',c);

a = - 42153689754
b = 7892456310201
результат:  - 332696154697212539380554
    
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?