В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Требуется написать программу уменьшения в два раза значение всех элементов массива, имеющих нечетные индексы

Ответ:
Stanmashyna201
Stanmashyna201
08.10.2020 00:22
Program v1;
Var  i,n: integer; 
 mas: array[1..100] of real;
   mas1: array[1..100] of real;  Begin
  Write ('Сколько элементов вы хотите:'); 
 Readln(n); 
 For i := 1 to n do 
Begin 
mas[i] := Random(30); 
  Write (mas[i],' '); 
 End; 
 Writeln;   
 For i := 1 to n do
 if (i mod 2 = 1) then 
 Begin   mas1[i] := mas[i]/2; 
  Write (mas1[i],' '); 
  End;   
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?