В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Алинаwlis
Алинаwlis
19.05.2020 03:23 •  Информатика

Составить программу которая сформирует целочисленный массив из n элементов и увеличит все элементы массива на значение максимального элемента. требования : n - не более заполнения массива - ввод значений с клавиатуры; наличие в массиве положительных и отрицательных элементов; вывод сопровождается: исходный массив, значение максимального элемента, печать массива после внесенных в него изменений, дружественный интерфейс

Ответ:
kettyperry16
kettyperry16
08.10.2020 00:09
var a: array[1..999] of integer;
var n, max: integer;
begin   
read(n);
    for var i := 1 to n do begin 
       read(a[i]); 
   end;   
for var i := 1 to n do begin   
    if a[i+1] > a[i] then 
      max := a[i+1];   
    write(a[i] + ' '); 
       if i = n then writeln;
    end;   
 writeln(max); 
  for var i := 1 to n do begin
      a[i] += max;   
      write(a[i] + ' '); 
  end;
end.
Составить программу которая сформирует целочисленный массив из n элементов и увеличит все элементы м
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?