В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mikhail2005com
mikhail2005com
16.11.2020 12:02 •  Информатика

Pascalabs составить программу которая определяет 1) является ли число положительным или отрицательным. 2) считает числа отрицательные и положительные. 3) считает сумму отрицательных и положительных

Ответ:
vladimir1232
vladimir1232
07.10.2020 23:53
Var a,i,k1,k2,s1,s2:integer;
begin
for i:=1 to 3 do begin
 readln(a);
 if a>0 then begin
  writeln('Число ',a,' положительное');
  k1:=k1+1; s1:=s1+a;
 end else if a<0 then begin
  writeln('Число ',a,' отрицательное');
  k2:=k2+1; s2:=s2+a;
 end;
 end;
writeln('Количество положительных = ',k1,', их сумма = ',s1);
writeln('Количество отрицательных = ',k2,', их сумма = ',s2);
end.

Пример:
15
Число 15 положительное
-74
Число -74 отрицательное
28
Число 28 положительное
Количество положительных = 2, их сумма = 43
Количество отрицательных = 1, их сумма = -74
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?