Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
xalka2004
16.10.2022 21:49 •
Информатика
Напишите программу на с++, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности
Ответ:
vasapipkin934
07.10.2020 23:47
#include <iostream>
#include <iomanip>
using namespace std;
int main() {
int n,k=0;
for (int i=0; ;) {
cin>>n;
if (n==0) break;
if (n%2==0 && n>0) k++;
}
cout<<k<<endl;
system("pause");
return 0;
}
3 -15 -18 14 7 9 -12 10 0
2
0,0
(0 оценок)
Популярные вопросы: Информатика
toshakotik
15.12.2022 05:56
Яв информатике - полный ноль. , ! : ( 1. статья содержит 32стр. на каждый стр. 40 строк. в каждой строке 64 символа, каждый символ кодируется 8 битами. вопрос: объём текста в килобайтах....
KenDipp
11.07.2021 12:20
Представить в римской системе счисления число 4876...
олеся788
11.07.2021 12:20
Перевести из десятичной в двоичной,2083,1999,255....
daleroks
08.03.2022 05:15
Вдвух байтах представлено число в формате с плавающей точкой. под мантису выделено 6 разрядов. 0000000100101001...
1234567890606
08.03.2022 05:15
)числа 139, 448 из десятичной системы счисления перевести в 2-ую, 8-ую, 16-ую; число с8 из 16-ой системы счисления перевести в 10-ую; число 74 из 8-ой системы счисления перевести...
99669888Nina
26.03.2020 12:32
Сообщение длиной 49152 символов занимает в памяти 66 кб найдите мощность алфавита...
arturk13
19.10.2022 16:36
Сколько единиц в двоичной записи числа 712?...
MariyaMirnaya
19.10.2022 16:36
Часовая стрелка повернулась с начала суток на d градусов. вывести, сколько с начала суток полных часов и минут. на вход программе подаётся целое число d от 0 до 360....
Qwan
19.10.2022 16:36
20 надо 1.текст длиной 20480 символов закодирован с алфавита содержащего 1024 символа сколько килобайт занимает в памяти этот текст 2. сообщение длиной 49152 символов занимает в...
nevessomost
04.06.2021 22:48
Переведите целое число из десятичной системы счисления в двоичную, число 181, с подробным объяснением, . никак не могу тему усвоить....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iomanip>
using namespace std;
int main() {
int n,k=0;
for (int i=0; ;) {
cin>>n;
if (n==0) break;
if (n%2==0 && n>0) k++;
}
cout<<k<<endl;
system("pause");
return 0;
}
3 -15 -18 14 7 9 -12 10 0
2