В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alexfuerte07
alexfuerte07
19.10.2022 10:10 •  Информатика

Нужно на паскаль написать программу, которая будет из данного ряда чисел (5,4,3,5,5,5,4) вычислять в столбец: 1) сколько 5 в данном ряду. 2) сколько 4 в данном ряду. 3) сколько 3 в данном ряду.

Ответ:
Максек1337
Максек1337
07.10.2020 23:41
Если нужно только эти числа(5,4,3,5,5,5,4), то вот программа.
var b,c1,c2,c3:integer;
a: array [1..7] of integer;
i: byte;
begina[1]:=5;
a[2]:=4;
a[3]:=3;
a[4]:=5;
a[5]:=5;
a[6]:=5;
a[7]:=4;
for i:= 1 to 7 do

begin
case a[i] of
3: c1:=c1+1;
4: c2:=c2+1;
5: c3:=c3+1;
end;
end;
writeln('Количество чисел 5 в данном ряду=',c3);
writeln('Количество чисел 4 в данном ряду=',c2);
writeln('Количество чисел 3 в данном ряду=',c1);
end.
0,0(0 оценок)
Ответ:
Ani32536
Ani32536
07.10.2020 23:41
Если нужно только эти числа(5,4,3,5,5,5,4), то вот программа.var b,c1,c2,c3:integer;a: array [1..7] of integer;i: byte;begina[1]:=5;a[2]:=4;a[3]:=3;a[4]:=5;a[5]:=5;a[6]:=5;a[7]:=4;for i:= 1 to 7 do
begincase a[i] of3: c1:=c1+1;4: c2:=c2+1;5: c3:=c3+1;end;end;writeln('Количество чисел 5 в данном ряду=',c3);writeln('Количество чисел 4 в данном ряду=',c2);writeln('Количество чисел 3 в данном ряду=',c1);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?