В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
TanNam123
TanNam123
07.03.2021 00:05 •  Информатика

Напишите программу треугольник со сторонами, надо. даны длины 3-х отрезков. нужно сказать, можно ли, соединяя отрезки концами, получить равносторонний, равнобедренный или разносторонний треугольники. или неравенство треугольника нарушено и его составить нельзя? input со стандартного устройства ввода вводятся через пробел 3 целых положительных числа, не превосходящих 10000 – длины отрезков. output нужно выдать на стандартное устройство вывода одно из следующих сообщений: “triangle is equilateral” – если треугольник равносторонний, “triangle is isosceles” – если треугольник равнобедренный, “triangle is scalene” – если треугольник разносторонний, “triangle is invalid” – если треугольника не существует. кавычки выводить не нужно

Ответ:
seregaushakov13
seregaushakov13
07.10.2020 23:30
Program Triangle;
var a,b,c:real;
begin
Read (a,b,c);
if (a+b>c)and(a+c>b)and(b+c>a)
then
  if (a=b)and(b=c)and(a=c)
  then write ('Triangle is scalene')
  else
    if (a=b)or(b=c)or(a=c)
    then write ('Triangle is isosceles')
    else write ('Triangle is equilateral')
else write('Triangle is invalid');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?