В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nelya2612
Nelya2612
26.01.2020 20:10 •  Информатика

Дано целое трехзначное число x составьте программу вычисления суммы и произведения цифр трехзначного числа x значения x ввести с клавиатуры

Ответ:
buharowaalina
buharowaalina
07.10.2020 23:22
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=abs(ReadInteger).Tostring.Select(x->x.ToDigit);
writeln('сумма цифр: ',a.Sum);
write('произведение цифр: ',a.Aggregate(Real(1),(x,y)->x*y));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?