В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Polina2050
Polina2050
06.03.2022 18:53 •  Информатика

Составить программу на паскале. вася делает за а часов, в минут, с секунд. ему необходимо выполнить n . сколько времени он потратит?

Ответ:
temnikovay01
temnikovay01
21.08.2020 10:58
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('Сколько часов, минут и секунд надо на задачу?');
  var n:=ReadInteger('Сколько задач?');
  var t:=n*(c+60*b+3600*a);
  Write('Будет затрачено ',t div 3600,' час ');
  t:=t mod 3600;
  Write(t div 60,' мин ',t mod 60,' c')
end.

Пример
Сколько часов, минут и секунд надо на задачу? 1 13 42
Сколько задач? 6
Будет затрачено 7 час 22 мин 12 c
0,0(0 оценок)
Ответ:
AdamM2
AdamM2
21.08.2020 10:58
Var a,b,c,n:integer;
begin
readln(a);
readln(b);
readln(c);
readln(n);
a:=a*3600;
b:=b*60;
c:=(c+a+b)*n;
a:=c div 3600;
b:=(c div 60)-(a*60);
c:=c-(b*60)-(a*3600);
writeln('Часы: ',a,' Минуты: ',b,' Секунды: ',c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?