В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gusakova2016poly
gusakova2016poly
12.08.2022 12:15 •  Информатика

Составить программу для вычисления функции. y={x^2,если х< 2 √х,если х ≥ 2 0,если х=2

Ответ:
LadyK15
LadyK15
07.10.2020 23:05
Задание не совсем верно построено. Скорее всего вторая проверка должна быть строго больше двух, однако вот решение:

program ff;

var
y,x:real;
begin
writeln('Введите x');
readln(x);
if x<2 then y:=sqr(x);
if x>=2 then y:=sqrt(x);
if x=2 then y:=0;
writeln('y=',y);
readln();
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?