В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mango34
mango34
10.07.2021 20:08 •  Информатика

С++ сортировка. дан одномерный массив целых чисел a[1..n]. напишите программу, которая перепишет в массив b[1..n] сначала в убывающем порядке все положительные элементы массива а, а затем в возрастающем порядке все отрицательные элементы массива а. например, для a = (4, -8, 7, -6, 0, -7, 5), получим b = (7, 5, 4, 0, -8, -7, -6).

Ответ:
olyasmirnova3
olyasmirnova3
21.08.2020 10:46
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
   int n,k;
   cout<<"n = ";  cin>>n;
   int a[n],b[n];
   srand(time(NULL));
// запись в массив
   for (int i=0; i<n; i++) { 
       a[i]=15-rand()%30; cout<<a[i]<<" "; 
   }    
   cout<<endl;
//  сортировка массива по убыванию
   for (int i=0; i<n-1; i++)
   for (int j=i+1; j<n; j++)
       if (a[j]>a[i]) swap(a[i],a[j]);
// поиск первого отрицательного
   k=0;
   while (a[k]>=0) k++;
// запись положительных по убыванию
   for (int i=0; i<k; i++) b[i]=a[i];
//  запись отрицательных по возрастанию
   for (int i=k; i<n; i++) b[i]=a[n-i+k-1];
// вывод массива b
   for (int i=0; i<n; i++) cout<<b[i]<<" ";
   cout<<endl;
   system("pause");
   return 0;
}

n = 15
 -6 -9 -7 12 7 7 -6 6 11 -4 1 10 9 -8 -1 
12 11 10 9 7 7 6 1 -9 -8 -7 -6 -6 -4 -1 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?