Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
salixova
08.12.2020 09:04 •
Информатика
Составьте программу которая находит сумму цифр трех значного числа на pascalabc
Ответ:
letochka111
10.09.2020 10:48
Program n1;
var a: integer;
begin
readln(a);
a:=abs(a);
write((a div 100)+ (a mod 10)+ (a mod 100 div 10));
end.
0,0
(0 оценок)
Ответ:
Айфон11111
10.09.2020 10:48
Var
i,n,s: Integer;
begin
write('Введите трехзначное число ');
read(n);
i:=0;
while (n<>0) Do
begin
s :=n Mod 10;
i:=i+s;
n:= n Div 10;
end;
writeLn('Сумма цифр : ',i)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Fobsliza
31.07.2022 17:12
Найдите сумму, разность двух чисел,вводимых с клавиатуры..результат представте в виде а=5 в=2 а+в=7 а-в=2...
0909044
19.04.2020 05:08
Нужно ! продумайте и изобразите в виде графа структуру следующего сайта: информатика ( школьный предмет)...
zver35
01.03.2022 11:29
Выделите те выражения, которые принимают значение False при выполнении условия «точка принадлежит заштрихованной области».1) х = 1.5 и y = 1.52) -2 x 2 и -3 y 23) x = 0 и y 24)...
полина1843
05.06.2020 10:33
Раскодируйте слово,состоящее из набора чисел 66 73 84,известно,что в таблице ascii значение a=65,b=66,c==90...
AndroidBot2018
05.06.2020 10:33
Python . пользователь вводит числа одно за другим до тех пор, пока не введёт ноль. никаких операций с числами не производится....
topcekstrimer
05.06.2020 10:33
Составьте программу,которая позволяет найти, вывести на экран второе слово строки s.строку s,состоящую из двух слов,разделенных пробелом,введите с клавиатуры. пример ввода зима...
enrnud6
25.01.2022 00:29
Статья, набранная на компьютере, содержит 64 страницы,на каждой странице 40 строк, в каждой строке 64 символа. определите размер статьи в кодировке кои-8 , в которой каждый символ...
ogurtsov2001
25.01.2022 00:29
Пользователь вводит ряд чисел (из количество он определяет сам, их количество находится в пределах от 1 до 100 включительно и является целым). числа, которые вводит пользователь,...
EvaMilka
03.05.2021 18:25
Если бы тебя попросили указать Какой признак по которому можно отличить от побега рябина Какой признак ты выбрал отрастания корней отсутствие корнейсодержание органических веществ...
Robobob
25.10.2020 09:05
-15.2163 +47. Как сделать этот пример? 7...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a: integer;
begin
readln(a);
a:=abs(a);
write((a div 100)+ (a mod 10)+ (a mod 100 div 10));
end.
i,n,s: Integer;
begin
write('Введите трехзначное число ');
read(n);
i:=0;
while (n<>0) Do
begin
s :=n Mod 10;
i:=i+s;
n:= n Div 10;
end;
writeLn('Сумма цифр : ',i)
end.