В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ник569078
Ник569078
25.05.2020 02:11 •  Информатика

Паскаль. много . дано целое трехначное число x.составьте программу вычисления суммы и произведения цифр трехзначного числа x. знасение x ввести с клавиатуры. тема с div и mod.

Ответ:
aiau2004
aiau2004
07.10.2020 22:15
//Pascal
//Для натуральных чисел
var a, s, p:integer;

begin
  write('Введите число = ');
  readln(a);
  s := 0;
  p := 1;
  while (a<>0) do
  begin
    p := p * (a mod 10);
    s := s + (a mod 10);
    a := a div 10;
  end;
 writeln( 'Сумма цифр числа = ', s);
 writeln( 'Произведение цифр числа = ', p);
end.

//Если число отрицательное
var
  s, p, a, b, c: integer;
  f: boolean;
begin
  write('Введите число = ');
  readln(a);
  if a < 0 then
    f := true;
  a := abs(a);
  b := a mod 10;
  a := a div 10;
  c := a mod 10;
  a := a div 10;
  if f = true then
  begin
    p := (-a) * b * c;
    s := -a + b + c;
  end
  else
  begin
    s := a + b + c;
    p := a * b * c;
  end;
  writeln('Сумма цифр числа = ', s);
  writeln('Произведение цифр числа = ', p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?