В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nottyt
Nottyt
26.02.2022 19:34 •  Информатика

(30 ). написать программу по информатике. задана следующая : удалить первый элемент кратный трем (в паскале). я плохо понимаю информатику,поэтому по возможности распишите программу целиком.

Ответ:
DOLTONrus
DOLTONrus
07.10.2020 22:14
Первый кратный элемент заменяется на 0
const     
n = 10; 
var   
a : array [1..n] of integer;  
 i,m : integer;  
    begin
  for i := 1 to n do 
   a[i] := i;              
 
 m := 0; 
  i := 1;
 while (m = 0)
 and (i<=n) do   
  begin  
    if a[i] mod 3 = 0 then 
      begin   
     a[i] := 0;   
     m := 1;  
     end ;  
    i := i +1; 
    end;   
 for i := 1 to n do  
  writeln (a[i]); 
  end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?