В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
прости17
прости17
06.09.2022 23:07 •  Информатика

Написать программу полностью. (паскаль) "найти индексы тех элементов массива, у которых значение больше, чем значение предыдущего элемента"

Ответ:
danilglazkov1259
danilglazkov1259
07.10.2020 22:11
Uses crt;
var a:array [1..100] of integer;
k,n,i:integer;
begin
clrscr;
write('Введите количество элементов массива=');
readln(n);
randomize;
for i:=1 to n do
a[i]:=random(45)-20;
writeln('Исходный массив');
for i:=1 to n do
 write(a[i]:6);
writeln;
for i:=1 to n-1 do
 if a[i+1]>a[i] then 
  writeln('Индексы: ',i:3);
writeln;
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?