В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
akbotawka02
akbotawka02
27.01.2023 16:59 •  Информатика

Паскаль: дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова, начинающиеся с гласных букв алфавита.

Ответ:
AlexKostrov
AlexKostrov
07.10.2020 22:08
var
i:integer;
s:string;
const
glas=['Й','У','Е','Ы','А','О','Э','Я','И','Ю'];
beginwrite ('Vvedite predlohenie: ');
readln (s);
i:=1;
while i<=length (s) do     
begin           
if ((i=1) or (s[i-1]=' ')) and (s[i] in glas) then           
begin             
while not ((s[i] in ['.',',',';','!','?',':',' '])) and (i<=length (s)) do                   
begin                         
write (s[i]);                         
i:=i+1;                   
end;             
writeln;           
end;         
i:=i+1;     
end;
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?