В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Женька2597
Женька2597
17.06.2021 09:09 •  Информатика

Информатика даны 3 числа a,b,c, составить программу, определяющую, существует от треугольник со сторонами a,b,c, и если существует, то является ли он прямоугольным, тупоугольным, остроугольным

Ответ:
алинаарсенова
алинаарсенова
07.10.2020 21:41
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите стороны треугольника:');
  if (a+b>c) and (a+c>b) and (b+c>a) then begin
    var alpha:=ArcCos((b*b+c*c-a*a)/(2*b*c));
    var beta:=ArcCos((a*a+c*c-b*b)/(2*a*c));
    var gamma:=Pi-alpha-beta;
    var max:=Max(Max(alpha,beta),gamma);
    var d:=max-Pi/2;
    if abs(d)<=1e-12 then Writeln('Треугольник прямоугольный')
    else if d<0 then Writeln('Треугольник остроугольный')
    else Writeln('Треугольник тупоугольный')
    end
  else Writeln('Треугольник не существует')
end.

Примеры
Введите стороны треугольника: 3.54 5.18 8.32
Треугольник тупоугольный

Введите стороны треугольника: 30 40 50
Треугольник прямоугольный
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?