В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bayosoz5oe5
bayosoz5oe5
11.04.2020 08:58 •  Информатика

Напишите программу. дана последовательность чисел, количество чисел неизвестно, оканчивается 0. найти сумму и количество чисел, оканчивающихся на 7 и кратных 3.

Ответ:
yanasyperyanaco
yanasyperyanaco
07.10.2020 21:37
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqIntegerWhile(t->t<>0).Where(t->(t mod 10=7) and (t mod 3=0))
      .ToArray;
  Writeln('Сумма ',a.Sum,', количество ',a.Count)
end.

Пример
33 -77 117 27 -15 0
Сумма 144, количество 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?