В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
timurgu08
timurgu08
28.01.2023 10:03 •  Информатика

Решить по информатике) нужно написать программу на паскале. тема: циклы вот условие) оргкомитет олимпиады решил организовать обзорную экскурсию для участников олимпиады. для этого был заказан двухэтажный автобус (участников олимпиады достаточно много и в обычный они не умещаются) высотой 437 сантиметров. на экскурсионном маршруте встречаются n мостов. жюри и оргкомитет олимпиады обеспокоены тем, что высокий двухэтажный автобус может не проехать под одним из них. им удалось выяснить точную высоту каждого из мостов. автобус может проехать под мостом тогда и только тогда, когда высота моста превосходит высоту автобуса. организаторам узнать, закончится ли экскурсия благополучно, а если нет, то установить, где произойдет авария. входные данные: во входном файле сначала содержится число n (1< =n< =1000). далее идут n натуральных чисел, не превосходящих 10000 - высоты мостов в сантиметрах в том порядке, в котором они встречаются на пути автобуса. выходные данные: в единственную строку выходного файла нужно вывести фразу "no crash", если экскурсия закончится благополучно. если же произойдет авария, то нужно вывести сообщение "crash k", где k - номер моста, где произойдет авария. фразы выводить без кавычек ровно с одним пробелом внутри.

Ответ:
idxanax
idxanax
07.10.2020 21:31
Var
tmp,n,i:integer;
begin
Readln(n);
for i:= 1 to n do begin
readln(tmp);
if tmp <= 437 then
begin
  Writeln('Crash ', i);
  halt;
end;
end;
Writeln('No Crash');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?