В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Zhanar161
Zhanar161
20.01.2021 12:46 •  Информатика

Составить программу 7 класс: автомобиль проезжает первую часть пути длиной в s1 км за t1 мин, участок пути длиной s2 км за t2 мин, и участок пути s3 км за t3 мин. найдите среднюю скорость автомобиля в км\ч.

Ответ:
vakla
vakla
07.10.2020 21:28
Var
s,t,s1,t1:real;
begin
Writeln('Введите s1 и t1');
Readln(s1,t1);
s:= s +s1; t:= t + t1;
Writeln('Введите s2 и t2');
Readln(s1,t1);
s:= s +s1; t:= t + t1;
Writeln('Введите s3 и t3');
Readln(s1,t1);
s:= s +s1; t:= t + t1;
t:= t / 60;
Writeln(s/t)
end.

Пример:
Введите s1 и t1
15 10
Введите s2 и t2
5 20
Введите s3 и t3
40 30
60
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?