В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alexksyx
alexksyx
05.04.2020 08:54 •  Информатика

Написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. размер последовательности определяет сам пользователь программы. принять, что последовательность состоит только из целых положительных чисел.

Ответ:
андрейка46
андрейка46
07.10.2020 21:35
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=ReadArrInteger(ReadInteger()).Where(x->x mod 8=0);
write('кол-во чисел, делящихся на 8 без остатка: ',a.Count(),'; сумма: ',a.Sum());
end.
0,0(0 оценок)
Ответ:
PO3TER
PO3TER
07.10.2020 21:35
Program qq;
var a, b, c, d, e:integer;
BEGIN
d:=0;
e:=0;
writeln('Введите количество чисел');
readln (a);
writeln ('Введите числа');
for b:=1 to a do
begin

readln (c);
if c mod 8 = 0 then
d:=d+c;
e:=e+1;
end;
Writeln ('Количество чисел кратных восьми - ', e, '; Их сумма - ', d);
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?