В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
angelinaosadchy
angelinaosadchy
07.11.2022 09:54 •  Информатика

Создайте программы в паскале : с клавиатуры вводится целое число x. • выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). • определите, количество делителей числа x не считая 1 и самого числа. • определите, является ли введенное число простым. • напиши программу, которая выведет на экран простые числа в диапазоне от n до m. n и m – целые числа, которые вводятся с клавиатуры.

Ответ:
ваниль2003
ваниль2003
07.10.2020 21:16
1)
Var
x, i: integer;
begin
Write('Введите X -> ');
readln(x);
Write(1, ' ');
for i:= 2 to x div 2 + 1 do
  if x mod i = 0 then
    Write(i, ' ');
Write(x);
end.

2)
Var
x,count, i: integer;
begin
Write('Введите X -> ');
readln(x);
for i:= 2 to x div 2 + 1 do
  if x mod i = 0 then
    count:= count + 1;
Writeln(count);   
end.
3)
Var
x, count, i: integer;
begin
Write('Введите X -> ');
readln(x);
for i:= 2 to x div 2 + 1 do
  if x mod i = 0 then
    count:= count + 1;
if count = 0 then Writeln('Простое')
else Writeln('Составное');   
end.

4)
Var
n,m, i, j: integer;
fl:boolean;
begin
Readln(n,m);
For i:= n to m do
  begin
  fl := true;
  for j:= 2 to i div 2 + 1 do
    if i mod j = 0 then fl := false;
  if (fl) then Write(i, ' ');
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?