В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Функция.напишите программу для нахождения наибольшего числа из 5 чисел. для сравнения двух чисел создать соответствующую функцию

Ответ:
azazaka220
azazaka220
07.10.2020 21:10
Function Max(a,b:real):real;
begin
  if a>b then Max:=a
  else Max:=b
end;

var
  a,b,c,d,e,m:real;
  i:integer;
    
begin
  Writeln('Введите 5 чисел: ');
  Read(a,b,c,d,e);
  m:=Max(a,b);
  m:=Max(m,c);
  m:=Max(m,d);
  m:=Max(m,e);
  Writeln('Максимум: ',m)
end.

Пример
Введите 5 чисел:
2.3 4 -5.16 0 0.087
Максимум: 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?