В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу через цикл while "найти произведение: p=(1+x) *(3+2x) *(5+ (n множителей). заранее )

Ответ:
6polih1
6polih1
04.08.2020 10:03
Var
  n: integer;
  x:real;
  p:double;

begin
  Writeln('Введите n и x');
  Read(n);Readln(x);p:=1;
  while (n > 0) do
    begin
      p:= p * (1 + 2*(n-1) + n*x);
      n:= n - 1;
    end;
  Writeln(p);
end.

Пример:
Введите n и x
3 2
231
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?