Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Показать больше
Показать меньше
Foxy4152
11.06.2021 10:25 •
Информатика
Паскаль: вывести название месяца и время года по введенному числу (можно через if или case)
Ответ:
Egoraptor
07.10.2020 20:59
Var mes: array[1..12] of string = ('январь','февраль','март', 'апрель',
'май','июнь','июль','август',
'сентябрь','октябрь','ноябрь','декабрь');
vr: array[0..3] of string = ('зима','весна','лето','осень');
n: integer;
begin
write('месяц: '); readln(n);
write(mes[n]);
n:=n mod 12;
write(' ',vr[n div 3]);
end.
месяц: 7
июль лето
месяц: 12
декабрь зима
0,0
(0 оценок)
Популярные вопросы: Информатика
poli1001
21.05.2023 14:29
Написать программу, которая выводит таблицу степеней двойки от 0 до 10. ниже представлен рекомендуемый вид экрана после выполнения программы: таблица степеней двойки: 0 1 2 3...
kirifili007
29.03.2022 03:58
Для закрытия окна приложения можно использовать комбинацию...
kanumah2
18.03.2020 11:03
Выберите правильный вариант глагола: if i were you, the concert. a)gone would go b) would go c) will go d) went e)going....
ltimofienko
18.03.2020 11:03
Write negative sentences with be going to example: (i/hot/ cook/a meal) i am going to cook a meal (friend/not/take/a shower/now/on monday) (we/hot/have/lunch/at school/on sunday)...
ОлимпМальчик321
18.03.2020 11:03
Как переводится колун машинанын эшигине кысып алды...
olesy1945
18.03.2020 11:03
Почему произведение называется золотой петух...
afkds
18.03.2020 11:03
Какое впечатление произвел на меня рассказ золотой петух? напишите...
kazmerovichvika
18.03.2020 11:03
На первой полке стояло 21 книга, что составляет 1 целая 1\2 от книг, стоящих на второй полке. сколько книг стояло на двух полках?...
lliza123
18.03.2020 11:03
Сумма длин гипотенузы и катета прямоугольного треугольника равна 9 см, а их разность равна 4 см. найдите другой катет....
spirt708ozrmv0
18.03.2020 11:03
Решите уравнение x+(6 2/5-4,91)=5,35...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
'май','июнь','июль','август',
'сентябрь','октябрь','ноябрь','декабрь');
vr: array[0..3] of string = ('зима','весна','лето','осень');
n: integer;
begin
write('месяц: '); readln(n);
write(mes[n]);
n:=n mod 12;
write(' ',vr[n div 3]);
end.
месяц: 7
июль лето
месяц: 12
декабрь зима