В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aze1234
aze1234
10.11.2022 07:36 •  Информатика

Нужно написать программу на pascal.даны натуральное число n и вещественные числа а1, а2, а3, аn. определить сумму квадратов вещественных чисел.

Ответ:
Andrey3355
Andrey3355
16.08.2020 17:20
Var
  i,n:integer;
  s,t:real;
 
begin
  Write('n='); Readln(n);
  s:=0;
  for i:=1 to n do begin
    Read(t);
    s:=s+t*t
    end;
  Writeln('Сумма квадратов равна ',s)
end.

Пример
n=5
-23.1 42.6 146 0 0.12
Сумма квадратов равна 23664.3844
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?