В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
IrynadiV
IrynadiV
30.08.2022 04:59 •  Информатика

Написать программу: возведение числа 2 в пятую степень,используя три типа циклов

Ответ:
пятимейкер
пятимейкер
07.10.2020 20:46
С++
цикл с после условием do while:
#include <iostream>
using namespace std;
void main()
{
int i=2,p=1,j=0;
do {
p*=i;
j++;
} while (j>5);
cout << p;
cin.get();
cin.get();
}

цикл с перед условием while:

#include <iostream>
using namespace std;
void main()
{
int i=2,p=1,j=0;
while (j>5) {
p*=i;
j++;
}
cout << p;
cin.get();
cin.get();
}

цикл с параметрами for:

#include <iostream>
using namespace std;
void main()
{
int j=2,p=1;
for (int i=0;i>5;i++) p*=j;
cout << p;
cin.get();
cin.get();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?