В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Versusmag228
Versusmag228
25.09.2021 03:57 •  Информатика

Составьте программу для вычисления суммы цифр заданного трехзначного числа. на паскале

Ответ:
mot1475
mot1475
10.08.2020 21:29
Var
  n:integer;
 
begin
  Write('n = '); Read(n);
  Writeln(n div 100+(n div 10) mod 10+n mod 10)
end.

Пояснения.
n div 100 дает первую цифру: результат деления нацело числа на 100.
(n div 10) mod 10 дает вторую цифру: вычисляется результат деления нацело числа на 10 и от него берется остаток деления на 10.
n mod 10 дает третью цифру: остаток целочисленного деления числа на 10.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?