В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dimasikmirnyy9
dimasikmirnyy9
11.01.2023 12:43 •  Информатика

Максимум .
нужно составить программу на паскале (ниже само ).

если хотя бы два числа из трех введенных чисел положительны, то
уменьшить каждое нечетное число на 1, иначе – найти сумму всех
чисел.

Ответ:
Умник333331
Умник333331
07.10.2020 20:34

var a,b,c,kol:integer;

 begin

   readln(a,b,c);

if a>0 then inc(kol);

if b>0 then inc(kol);

if c>0 then inc(kol);

if kol>=2 then

                      begin

                        if a mod 2=1 then dec(a);

                        if b mod 2=1 then dec(b);

                        if c mod 2=1 then dec(c);

                      end

  else writeln(a+b+c);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?