В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
djamilaalieva
djamilaalieva
14.03.2021 20:37 •  Информатика

Создайте функцию которая считает с клавиатуры символьный массив и затем рассчитывает количество символов во введенной строке. напишите программу, которая позволяет с пользованием созданной функции считаnь с клавиатуры строку и вывести на экран количество символов в ней (с++)

Ответ:
кен91
кен91
07.10.2020 20:28
#include <iostream>

using namespace std;

void countChars() {
    char s[256];
    cout << "Введите строку: ";
    cin.getline(s, 256);

    int count = 0;
    for (unsigned int i = 0; i < strlen(s); i++)
        count++;
   
    cout << "Количество символов в строке: " << count << endl;
}

int main() {
    setlocale(LC_ALL, "Russian");
    countChars();
    system("pause");
    return 0;
}

//
// или так
//

#include <iostream>

using namespace std;

int countChars(char* s) {
    int count = 0;
    for (unsigned int i = 0; i < strlen(s); i++)
        count++;
    return count;
}

int main() {
    setlocale(LC_ALL, "Russian");
    char s[256];
    cout << "Введите строку: ";
    cin.getline(s, 256);
    cout << "Количество символов в строке: " << countChars(s) << endl;
    system("pause");
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?