В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Camelia1980
Camelia1980
14.01.2020 00:16 •  Информатика

Напишите программу которая для введённой пары положительных чисел, большее число делит на меньшее до того, пока оно не станет меньше единицы

Ответ:
serjksu
serjksu
10.08.2020 21:23
П0 <-> П1 - x<0 13 ИП0 П2 ИП1 П0 ИП2 П1
ИП0 1 - x<0 22 ИП0 ИП1 / П0 ИП0 С/П
0,0(0 оценок)
Ответ:
NASTUHA6
NASTUHA6
10.08.2020 21:23
Var
  a,b,t:real;

begin
  Write('Введите через пробел два положительных числа: ');
  Read(a,b);
  if b>a then begin t:=a; a:=b; b:=t end;
  repeat
    a:=a/b
  until a<1;
  Writeln(a)
end.

Пример
Введите через пробел два положительных числа: 1.7 153.4
0.760915000615007
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?