В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sakyra225
sakyra225
07.04.2022 20:15 •  Информатика

Даны первые элементы последовательности чисел 4.7.10. составьте программу которая вычислит и выведет на экран монитора сумму элементов заданной последовательности значение которых меньше 25 на паскале))

Ответ:
неманема
неманема
07.10.2020 20:24
Program Test;

Var
a1, a2, d, k, max, tmp: integer;
sum: real;
rule: boolean;

Begin

Writeln('Введите а1 и а2');
Readl(a1, a2);

k := 2;
d := a2 - a1;
rule := true;

while (rule = true) do
begin
k := k + 1;
tmp := a1 + k * d;

if (tmp < 50) then
max := tmp

else
rule := false;

end;

sum := (a1 + max) / 2 * k;

Writeln();
Writeln('Сумма = ', sum);

End.


Программа будет работать только для арифметических прогрессий, например, таких, как последовательность из задания. Вводить нужно 2 целых числа (первые два члена прогрессии) через пробел (в вашем случае 4 и 7)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?