В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Икари301202
Икари301202
03.02.2023 03:53 •  Информатика

Все сови : написать программу котораяопределяет является ли число четнымили его запись окончательно целая 7

Ответ:
Liza1556
Liza1556
07.10.2020 20:18
Var
num: integer;
begin
read(num);
if num mod 2 = 0 then write('Число четное') else write('Число нечетное');
end.
0,0(0 оценок)
Ответ:
irochkakarpenkp0bint
irochkakarpenkp0bint
07.10.2020 20:18
Var
  n:integer;

begin
  Write('n = '); Read(n);
  if (n mod 2=0) then Writeln('Число четное')
  else begin
    Write('Число нечетное и оно ');
    if Abs(n mod 10)<>7 then Write('не ');
    Writeln('оканчивается цифрой 7')
    end
end.

Примеры
n = 3538
Число четное

n = 642301
Число нечетное и оно не оканчивается цифрой 7

n = 6306547
Число нечетное и оно оканчивается цифрой 7

n = -546347
Число нечетное и оно оканчивается цифрой 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?