В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kojjd
Kojjd
21.05.2022 13:38 •  Информатика

Написать программу в паскале. входные данные : вводятся 4 числа, а, b, c, d выходные данные : найдите все целые решения уравнения ax^3+bx^2+cx+d=0 на отрезке [0,1000] и выведите их в порядке возрастания. если на данном отрезке нет ни одного решения, то ничего выводить не нужно.

Ответ:
inlivemulorada
inlivemulorada
07.10.2020 20:15
//PascalABC.NET
//Версия 3.3, сборка 1611 (06.01.2018)

begin
  var (a,b):=ReadInteger2('Введите a,b,c,d->');
  var (c,d):=ReadInteger2;
  Write('Корни: ');
  for var x:=0 to 1000 do
   if a*x**3+b*x**2+c*x+d=0 then Write(x,' ');
end.

Пример:
Введите a,b,c,d-> 1 -3 -13 15
Корни: 1 5 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?