В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
луч16
луч16
12.03.2021 06:19 •  Информатика

Сна паскаль!
составить программу для решения : дано натуральное число n. вычислить , определяемое как произведение честных чисел от 2 до n, если n честно, либо как произведение нечетных чисел от 1 до n, если n нечетно.

Ответ:
angelinashushina
angelinashushina
07.10.2020 20:02

program raf105;

var

 n,pro: integer;

begin

 write('n = ');

 readln(n);

 pro:= n;

 while n-2 > 0 do

 begin

   pro:= pro * (n-2);

   n:= n - 2;

 end;

 writeln('Вывод: ',pro);

end.

PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?