В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Krisru376
Krisru376
11.06.2021 08:10 •  Информатика

Написать программу на паскале. найти 11 последовательных натуральных чисел, сумма квадратов которых сама является квадратом натурального числа.

Ответ:
umida9501
umida9501
07.10.2020 20:07
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var t: real;
var i:=1;
while true do
begin
t:=range(i,i+10).Select(x->x*x).Sum();
if (frac(sqrt(t))=0) then break;
inc(i);
end;
range(i,i+10).Println();
end.
0,0(0 оценок)
Ответ:
викуха307
викуха307
07.10.2020 20:07
Var
  i,n,s:integer;

begin
  n:=1;
  while true do begin
    s:=0;
    for i:=n to n+10 do s:=s+i*i;
    if s=Sqr(Trunc(Sqrt(s))) then break;
    n:=n+1
    end;
  Write('Сумма квадратов чисел на интервале [',n,';',n+10,'] = ');
  Writeln(s,' = ',Trunc(Sqrt(s)),'^2')
end.

Результат
Сумма квадратов чисел на интервале [18;28] = 5929 = 77^2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?