Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Georgiy11111
08.10.2020 06:02 •
Информатика
Добрые люди ! решить данную на паскале напишите программу, чтобы создавала палиндром любой строки. палиндром - исходная строка + обратное представление строки (на входе – abc; на выходе abccba)
Ответ:
nastushka208
07.10.2020 19:54
1. Современное решение
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
s:=s+s.Inverse;
s.Println
end.
Пример
abc
abccba
2. Так все еще учат в большинстве (но уже не во всех!) школ
program Palindrom;
var
s:string;
i,n:integer;
begin
Readln(s);
for i:=Length(s) downto 1 do s:=s+s[i];
Writeln(s)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
kotik259
27.02.2023 16:09
Написать путь к файлу КР.doc...
Ḱặрặṃềӆьҟӑ
31.08.2022 05:07
Определите информационный объем сообщения толерантность , записанного с символьного алфавита ( кавычки не учитывать)...
ПудинговыйГраф
23.09.2020 04:40
Выбери основные типы данных MS Excel...
lord50
12.03.2023 02:22
Можно ли менять Формат ячеек? ребят...
XxXBulykXxX
11.05.2023 22:50
Задан массив A из N элементов. Какое условие надо поставить вместо многоточия, чтобы найти количество неотрицательных элементов массива в переменной k? k = 0 for k in range(N):...
Усварппоры
30.12.2021 06:28
До 22:00информатика с.745 класс ...
Masha00317
14.02.2023 07:34
составить программу 1) экзамен по информатике сдавали 10 человек. сколько из них получили оценку «5»? 2) изменить программу так, чтобы вычислить количество учеников сдавших экзамен...
rahat9
07.10.2020 15:04
Окакой функции денег говорится в фрагменте? счастливый день! могу сегодня я в шестой сундук (в сундук еще неполный) горсть золота накопленного всыпать. не много, кажется, но...
Nikitos31055
07.10.2020 15:04
Как найти боковые стороны равнобедренной трапеции если известна средняя линия. как...
VanoK48
07.10.2020 15:04
Вравнобедренный треугольник abc ( ab=bc )вписан ромб, один и углов которого совпадает с углом bтреугольника, а противоположная ему вершина лежит на основании ac. найдите плоадь...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
s:=s+s.Inverse;
s.Println
end.
Пример
abc
abccba
2. Так все еще учат в большинстве (но уже не во всех!) школ
program Palindrom;
var
s:string;
i,n:integer;
begin
Readln(s);
for i:=Length(s) downto 1 do s:=s+s[i];
Writeln(s)
end.